apache 2.2.2 + PHP5.1.4 不能运行的解决办法

apache 2.2.2 + PHP5.1.4 不能运行的解决办法

问题,使用传统的模块化方法安装PHP5.1.* + apache 2.2.2 后不能启动,

提示:
"Cannot load C:/php/php5apache2.dll into server: The specified module could not be found."


原因:

PHP压缩包里的php5apache2.dll只适用于apache2.0.*

解决方法:

下载 [这个文件] 并解压.共有三个文件.

vcredist_x86.exe
php5apache2.dll
httpd.exe.manifest


好,开始

1.将 php5apache2.dll 覆盖掉你原来PHP目录下的 php5apache2.dll 文件.

2.将 httpd.exe.manifest 文件复制到你的apache安装目录下的bin文件夹下.

3.双击运行vcredist_x86.exe安装.(如果您的系统里已安装了 .NET framework 2.就可以省掉这一步)

完成!去重启你的apache2.2试试吧.

[ 本帖最后由 我不是鱼 于 2008-10-9 17:38 编辑 ]
如履薄冰

这个解决方法太好了

由于本人装的是APACHE2。23 所以出现apache不能启动,搜索到贵站的解决方案,才把问题解决,感谢楼主下
那个文件为什么我安不上?
感谢LZ!!
我也遇到2楼的问题~
还是装2.0.X吧
问题依旧1我用的是APACHE2。23。。装了
vcredist_x86.exe
php5apache2.dll
httpd.exe.manifest
这三个文件之后APACHE2。3启动无反应了。。为什么???
apache2.3能启动了,但是还是无法访问文件,
出现403错误
不知这是什么原因(注:机子没有防火墙之类的软件)
引用:
原帖由 seaqing 于 2006-9-16 19:27 发表
由于本人装的是APACHE2。23 所以出现apache不能启动,搜索到贵站的解决方案,才把问题解决,感谢楼主下
偶也是,谢谢楼主
非常感谢
加入环境变两
引用:
原帖由 javayang 于 2006-11-1 14:47 发表
加入环境变两
什么内容啊???
静坐常思己过