首页 | 新闻 | 交流 | 问吧 | 文档 | 手册 | 下载 | 博客

收藏此问题 发表新评论

我用tools.php检测结果

===配置文件检查=================================================

        数据库正常链接.
        pconnect ---> 数据库是否持久连接 ---> 非持久链接

        cookiepre ---> cookie 前缀 ---> TkG_

        cookiedomain ---> cookie 作用域 ---> 空

        cookiepath ---> cookie 作用路径 ---> /

        tablepre ---> 表名前缀 ---> cdb_ ---> 正常

        dbcharset ---> MySQL链接字符集 ---> 空

        charset ---> 论坛字符集 ---> utf-8

        headercharset ---> 强制论坛页面使用默认字符集 ---> 未开启

        tplrefresh ---> 论坛风格模板自动刷新开关 ---> 开启

        forumfounders ---> 论坛创始人uid ---> 1 ---> 正常

        dbreport ---> 是否发送错误报告给管理员 ---> 不发送错误报告

        errorreport ---> 是否屏蔽程序错误信息 ---> 屏蔽程序错误

        attackevasive ---> 论坛防御级别 ---> 0

        admincp['forcesecques'] ---> 管理人员是否必须设置安全提问才能进入系统设置 ---> 否 > 警告:有安全隐患

        admincp['checkip'] ---> 后台管理操作是否验证管理员的 IP ---> 是

        admincp['tpledit'] ---> 是否允许在线编辑论坛模板 ---> 否

        admincp['runquery'] ---> 是否允许后台运行 SQL 语句 ---> 否

        admincp['dbimport'] ---> 是否允许后台恢复论坛数据 ---> 是 > 警告:有安全隐患

===系统环境检查=================================================

        操作系统--->Linux

        WEB 引擎 --->Apache/2.0.61 (Unix) PHP/5.2.3

        PHP 版本--->5.2.3

        MySQL 版本--->6.0.2-alpha

        Zend 版本--->没有安装或版本较低

        程序最长运行时间(max_execution_time)--->不限制秒

        内存大小(memory_limit)--->

        是否允许打开远程文件(allow_url_fopen)--->允许

        是否允许使用短标记(short_open_tag)--->允许

        安全模式(safe_mode)--->关闭

        错误提示(display_errors)--->开启

        XML 解析器--->可用

        authkey 是否存在--->存在

        系统临时目录--->不可写

        磁盘空间--->760M

        附件上传--->您可以上传附件的最大尺寸: 2M

        函数 file()--->存在

        函数 fopen()--->存在

        目录权限---文件及目录属性全部正确

        GD 库--->您的php.ini未开启extension=php_gd2.dll(windows)或者未编译gd库(linux).

        ming 库--->您的系统支持flash验证码,如果还无法使用flash验证码的话,有可能是您的php版本太低

        ImageMagick --->您现在只需安装好ImageMagick,然后配置好相关参数就可以使用ImageMagick(使用之前请先使用后台的预览功能来检查您的ImageMagick是否安装好)

        系统环境错误提示
        您的ZEND版本低于3.0,将无法使用SuperSite.
===文件错误检查=================================================

---------论坛根目录下没有检测到有错误的php文件.

---------模板缓存目录(forumdata/templates)下没有检测到有错误的缓存文件.

---------其它缓存目录(forumdata/cache)下没有检测到有错误的缓存文件.

===检查完毕=====================================================
#cd ZendOptimizer-3.3.0-linux-glibc21
#./install.sh
跟据提示:有一个php.ini目录添写/usr/local/php5/lib完成安装就可以了
#cd /usr/local/Zend/lib/
#cp /usr/local/Zend/lib/Optimizer-3.3.0/php-5.2.x/ZendOptimizer.so /usr/local/Zend/lib/
#cd /usr/local/php5/lib
#vi php.ini  添加到最后
zend_optimizer.optimization_level=1023  //优化程度,这里定义启动
zend_optimizer.encoder_loader=0  //不允许处理由Zend Encoder加密的PHP文件
zend_extension_ts=/usr/local/Zend/lib/ZendOptimizer.so  //优化器所在目录
请大伙帮忙看一下啊.指点一二.
昵称: yjypm530  时间: 2008-01-12 16:02:00
怎么没有人遇到过这样的问题吗?
昵称: yjypm530  时间: 2008-02-01 14:29:00
用phpinfo()的输出验证下,是否安装了Zend Optimizer 3.0
昵称: hosander  时间: 2008-02-02 10:21:00
SORRY
昵称: php?  时间: 2008-02-04 02:21:00