首页 | 新闻 | 交流 | 问吧 | 文档 | 手册 | 下载 | 博客

收藏此问题 发表新评论

discuz安装问题...

我的XP装了appserv和zend,现在想安装discuz结果提示mysql不支持
//*记得没装zend前装discuz应该没问题*//

这是我phpinfo.php里的部分内容
//*
Configuration File (php.ini) Path  C:\WINDOWS  
Loaded Configuration File  D:\Zend\Core\etc\php.ini
*//
这是C:\Windows\php.ini 的部分内容
//*
[MySQL]
.....
mysql.default_port =
......
mysql.default_socket =
......
mysql.default_host =
.......
mysql.default_user =
.......
mysql.default_password =
.....
*//
这是安装discuz造成不支持mysql的原因吗
昵称: 5iphp  时间: 2008-03-24 21:48:00
找到原因了...
我装zend时候安装了zend core[我也不知道这是干什么的...],
就是他里面有个需要配置mysql的路径跟appserv冲突了[貌似是这样...]
C:\Windows调用的php.ini是zend core里的[这个貌似因为安装时候冲突,有过配置中断]
而不是appserv安装时候自带的php.ini文件,
所以才会在安装discuz时候提示不支持mysql.

解决方法:
卸载zend core 重新启动[php.ini貌似会被自动更新到appserv里的php.ini]
安装discuz   OK....
[非专业人事哈,希望给有同样问题的朋友提示]
昵称: 5iphp  时间: 2008-03-24 22:15:00
Zend Core一般是用来在WIN下装Platform而预装的,如果不装Platform就不需要安装Zend Core.
昵称: zendchina  时间: 2008-03-25 09:00:00