首页 | 新闻 | 交流 | 问吧 | 文档 | 手册 | 下载 | 博客

Python开发环境配置

作者:  时间: 2011-03-24

”工欲善其事,必先利其器“。上篇序主要是介绍了python的一些基本信息,而作为开发所用,我们必须首先保障有一个稳定,好用的开发环境。本文中讨论的是python3.2版本,其实也可以是python2.7版本及其他版本,下面主要介绍两款开发工具。PyScripter和Eclipse。

1:首先介绍的这款是Pyscripter,首先截个图看下效果。

 

整体用起来感觉不错,有一定智能提示功能,且对代码缩进有一定的要求,如果代码缩进不正确的话,会提示syntax error:  expected an indented block。但是与python中所带的Lib文件夹下的模板程序关联不上,所以在引入和调用的时候会出现错误。

2:下面介绍的就是如何在eclipse配置python环境,首先也截个效果图。

 

         在eclipse中则很好的解决了上述“模板程序关联不上的错误”。下面主要介绍配置步骤。

基本需求:
 ·1 eclipse3.4以上,推荐3.6版本 
·2  python3.2 2.7版本也可以

步骤1:

下载用于在Eclipse中开发Python的插件PyDev。

文件名:org.python.pydev.feature-1.6.5.zip。

下载地址:http://sourceforge.net/projects/pydev/

步骤2:

解压org.python.pydev.feature-1.6.1.5.zip。将解压后的features和plugins文件夹中的内容拷贝到Eclipse安装目录下相同的文件夹中即安装PyDev插件成功。

步骤3:

打开Eclipse(如果已经打开,则重启Eclipse)。选择window——》Presences,设置如图:

 

展开PyDev,选择Interpreter - Python,单击New...按钮,在弹出的Select interpreter窗 口中单击Browse...按钮,找到已经安装的Python解释器。单击Select interpreter窗口中 单击OK按钮,在弹出的Selection Needed窗口中单击Select All按钮,然后单击OK按 钮完成设置。然后在Preferences窗口中选择Apply——》OK完成设置。如图:

 

以下几步Python 3.2必选,Python 2.7可以不考虑。主要是配置字符集编码。

1、General->Editors->Text Editors->Spelling,Encoding改成Other:UTF-8

2、General->Workspace,Text file encoding改成Other:UTF-8

然后就可以创建工程进行开发了。